Installing Vista SP1 on Ultimate

Hmm… I really thought MS were getting better at error messages. Basically it told me that my Windows Vista Ultimate was not supported by the English language service pack.. how odd:

“Windows Vista Service Pack 1 cannot be installed on your computer because the language of Windows Vista you have installed is not supported or you have installed a language pack that is not supported.
Windows Vista Service pack 1 can only be installed on computers running the English, French, German, Japanese and Spanish versions of Windows Vista or computers running only those language packs.”

Esspecially since my version was English.. maybe not English enough? I think this is the point where most people gave up, and I went looking for a kb.

The answer is easy! Because it was Ultimate edition, I had installed another language NOT listed above! Well, fine, but does it:

a) Mean I can’t upgrade?

b) At least tell me in the dialog box that this could be the problem?

So ‘all’ I have to do is remove the extreemly offensive foreign language and install again. I think Microsoft just wants users to suffer for buying Ultimate edition…

kb in question

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s